What are the system requirements to use Mediacom internet service?

At this time, there are no official and specific system requirements to use Mediacom
service. Any computer running Windows XP or newer, or running Mac OS X, should be
capable of connecting to our service, as long as it has an ethernet card. Older operating
systems may work with our service, but we cannot guarantee they will, nor can we provide
technical support for using them.